ZipGenius 1.4

Benvenuto nella Guida di ZipGenius!

In questa guida troverai tantissime informazioni che ti aiuteranno a scoprire e usare al meglio ogni funzione del programma che hai scaricato dalla Rete.

Grazie per aver preferito ZipGenius fra tanti altri programmi concorrenti.

M.Dev Software


Perché è spesso necessario comprimere i files?

La risposta a questa domanda diventata sempre più ovvio col passare del tempo e il conseguente diffondersi di Internet: perché il modo di lavorare di domani è già arrivato. Oggi molte persone collaborano a distanza via Internet e spesso non si sono mai incontrate personalmente, anche se insieme sviluppano progetti e altro; per poter lavorare queste persone sono costrette a spedirsi documenti di ogni genere tramite Internet. Se questi documenti fossero inviati così come sono stati creati (cioé: non compressi), il trasferimento di quei files diventerebbe un'operazione lunghissima, noiosa e improduttiva, che non apporterebbe alcun beneficio alla produttività dell'azienda di cui i due "colleghi a distanza" sono dipendenti; al contrario, i programmi di compressione permettono loro di ridurre le dimensioni dei files che vogliono scambiarsi e, nel contempo, consentono di inviare più files contemporaneamente, compressi in un unico file. Tutto ciò non fa altro che rendere il loro telelavoro molto più veloce e produttivo.

Ma i vantaggi della compressione non sono riservati ai soli lavoratori. Chiunque può trarre beneficio dalla compressione dei files: gli studenti, per esempio, possono archiviare le loro ricerche su Internet e portarle a scuola in un floppy o in un CD-R, mentre, gli artisti del fotoritocco possono scambiarsi immagini in modo molto più agevole tramite i files zip.

Gli archivi compressi, inoltre, possono risultare molto utili anche se si desidera eseguire un backup dei dati più importanti come i files vitali del sistema, e proprio ZipGenius 1.4 è stato dotato di potenti funzioni di backup, in modo da consentire l'immediato recupero di tutti i dati eventualmente perduti.


Archivi supportati da ZipGenius

ZipGenius (come il nome lascia intendere) attua un pieno controllo sugli archivi in formato ZIP, ai quali ha affiancato una forma speciale di archivio: CZIP. Questo tipo di archivio non è altro che un ARCHIVIO ZIP CRIPTATO tramite una chiave numerica tripla. Questo formato può essere letto soltanto da ZipGenius 1.4 o versioni successive e da nessun altro programma concorrente, comprese le precedenti versioni di ZipGenius per le quali, però, è disponibile un accessorio che consente di decriptare gli archivi CZIP.
Oltre questi, ZipGenius può gestire più o meno direttamente altri formati di compressione/archiviazione. Ecco quali sono (per avere maggiori informazioni su un tipo di archivio, clicca sulla sua estensione):

  • ZIP / CZIP: tutte le funzioni.
  • CAB: questi archivi sono gestiti quasi come i files ZIP e non è richiesto un programma esterno.
  • RAR, ACE: questi files possono essere letti e ZipGenius può estrarre files da essi. Compressione non supportata.
  • ARJ, ARC, GZIP, LHA/LZH, ZOO: ZipGenius può aprire questi archivi per leggerne il contenuto, ma è necessario un apposito programma esterno per modificare il contenuto o per creare archivi di questo tipo.
  • PAK: ZipGenius può creare, leggere e decomprimere archivi di questo tipo.


Caratteristiche di ZipGenius 1.4

  • 14 tipi di archivi supportati
  • 4 diverse modalità di visualizzazione dei files archiviati
  • 5 livelli di compressione (archiviazione files + 4 liv. di compressione)
  • Lettura automatica del commento dei files zip
  • Supporto per la creazione e la lettura della FIRMA nei files zip
  • Totale integrazione con Windows 98/ME/2000
  • Invio di archivi o di files estratti singolarmente tramite il programma e-mail predefinito.
  • Pubblicazione di archivi o di singoli files estratti su Internet
  • Esportazione lista dei files nei formati (HTML, DOC, XLS, CSV, XML, TXT)
  • Installazione dei programmi archiviati
  • Lettura automatica dei files ReadMe.txt tramite editor interno, con la possibilità di rilevare in questi i collegamenti a indirizzi Web o E-mail
  • Creazione di files autoestraenti (SFX) con funzioni avanzate, in grado persino di avviare l'installazione di un programma eventualmente archiviato (utile per gli sviluppatori di software)
  • Drag and drop per aggiungere o estrarre files da un archivio
  • Diverse configurazioni per utenti normali ed esperti
  • Assistente per il Primo Passo
  • Interfaccia bilingue (italiano ed inglese)
  • Possibilità di interazione con accessori esterni
  • Gestione da riga di comando (command line)
  • FTPGenius (ftp client incorporato - nuova versione: consente l'upload dei files)
  • Collector (utilità di ricerca archivi nel sistema)
  • Cutter (utilità per la divisione dei files in parti più piccole e viceversa)


Aggiornamenti

Lo sviluppo di ZipGenius non si ferma subito dopo la pubblicazione di una nuova versione, ma prosegue (teoricamente) all'infinito, pertanto talvolta sarà necessario aggiornare la copia di ZipGenius in Tuo possesso.

La procedura di aggiornamento è automatica: tu non devi fare altro che aprire il menù "Aiuto" e cliccare su "Aggiornamenti"; ZipGenius tenterà di connettersi via Internet al sito M.Dev Software, presso il quale è depositato un file contente il numero dell'ultima versione disponibile on-line e informazioni aggiuntive. Il tuo ZipGenius scaricherà quel file e confronterà il proprio numero di versione con quello riportato nel file: nel caso il Tuo ZipGenius risultasse più "vecchio" rispetto a quello disponibile on-line, ZipGenius mostrerà le informazioni aggiuntive nella lingua prescelta (generalmente: le novità e le correzioni rispetto alla versione precedente). ZipGenius chiederà poi se si desidera scaricare l'aggiornamento, che normalmente potrebbe consistere in alcune "patch" che saranno automaticamente installate subito dopo il download; altre volte, però, l'aggiornamento potrebbe essere consistente e comportare, quindi, un'innovazione tale da richiedere il download completo del programma: in questo caso l'installazione non sarà automatica, poiché sarà prima necessario disinstallare la versione corrente.


Requisiti di sistema

Requisiti minimi:

    • CPU Pentium 100 MHz
    • 16 Mb RAM
    • 8 Mb di spazio su hard disk
    • Mouse

Requisiti suggeriti:

    • CPU Pentium 133 MHz
    • 32 Mb RAM
    • 8 Mb di spazio su hard disk
    • Mouse
    • Modem e accesso a Internet


Barre degli strumenti

  • Principale
  • Altri comandi
  • Comandi avanzati

Se vuoi usare i bottoni senza le rispettive etichette, clicca con il tasto del mouse su una barra qualsiasi e deseleziona la voce "Mostra etichette dei bottoni".


Assistente "Primo Passo"

Questo tasto permette agli utenti che usano laconfigurazione normale di accedere alle funzioni avanzate di ZipGenius.Apparirà una finestra in cui sarà possibile scegliere una fra le tantefunzioni offerte, secondo che un archivio sia stato aperto o meno; cliccando"OK" il programma avvierà la funzione prescelta e la completeràquasi automaticamente, con un intervento minimo (e persino nullo in alcuni casi) da parte dell'utente.

Come accennato, non tutte le funzioni sono sempre disponibili: alcune, infatti, sono accessibili se - per esempio - è stato aperto un archivio o se questo è stato creato con un formato diverso da zip: ZipGenius provvederà a disabililtare automaticamente tali funzioni.


I dialoghi di ZipGenius 1.4

A differenza di tanti altri programmi, ZipGenius1.4, si serve di un dialogo di apertura files diverso, simile a quello giàusato in Office 2000 e ritrovato su Windows 2000; entrambi usanoun dialogo di apertura in grado di aprire direttamente cinque percorsipredefiniti: ZipGenius, invece, fa anche di più. Non solo è possibile accederea sei percorsi predefiniti, ma è anche possibile aggiungere ai dialoghidei percorsi preferiti, come nel caso della cartella "G:\Download"nella figura 2.

Fig.1: i sei percorsi predefiniti...

Fig. 2: le cartelle preferite.

Per aggiungere una cartella alla scheda dellepreferite, basta andare alla cartella stessa (oppure scriverne il percorsocompleto in "Nome file") e premere il tasto "Aggiungi cartella...".

Per visualizzare l'elenco delle cartellepreferite, basta cliccare sulla linguetta "Preferiti"nella barra laterale: i percorsi predefiniti lasceranno il posto a quelli date aggiunti.

Per rimuovere le cartelle preferite clicca su "Azzera lista preferiti".

ATTENZIONE! In Windows 95 e Windows NT 4 i dialoghi non disporranno delle funzioni sopra citate, a causa di limitazioni tecniche imposte da queste due vecchie versioni dei sistemi operativi.


Integrazione con Windows

ZipGenius è disegnato per integrarsi al meglio con Windows. Dopo l'installazione, infatti, ZipGenius avrà a disposizione due menù contestuali associati rispettivamente ai soli archivi zip e a tutti gli altri files e cartelle. Per fare apparire uno di questi menù bisogna selezionare un file e cliccare con il tasto destro del mouse.

Estrai
Questo comando provoca la comparsa del dialogo per l'estrazione dei files.

Pubblica su Internet
Attiva FTPGenius e trasferisce gli archivi selezionati su un server FTP (sul tuo sito, in pratica).

Spedisci via e-mail
Ti permette di creare un nuovo messaggio e-mail, cui troverai allegati i files selezionati. Questa funzione sfrutta il programma e-mail predefinito nel tuo sistema: se nessun programma e-mail è installato, puoi usare ZipGenius Mail.

Crea EXE
Trasforma l'archivio zip selezionato in un archivio autoestraente (SFX).

Contenuto
Farà apparire una finestra riportante il contenuto dell'archivio selezionato.

Estrai in [percorso]
Estrae automaticamente tutti i files nella percorso indicato.

Installa
Estrare tutti i files dall'archivio e avvia l'installazione. Questo comando è disponibile solo se il file zip è contenuto il file "setup.exe ".

Questo è invece il menù associato agli altri tipi di files o cartelle.

Aggiungi
Aggiunge i files selezionati ad un archivio.

Crea [nome archivio].zip
Crea un nuovo archivio con i files selezionati e gli assegnerà il nome di uno dei suddetti files.

Crea e spedisci via e-mail
Come il comando precedente: crea un archivio e, in più, prepara un nuovo messaggio e-mail.

ZipGenius inoltre può comunicare sottoforma di suggerimento il numero di files contenuti in un archivio zip, più altre informazioni (se presenti) come la firma, il commento o l'eventuale presenza di un programma di installazione nell'archivio selezionato.

Inoltre è anche possibile trascinare files sopra un archivio zip per aggiungerli a quello.


Impostazioni generali

Nella prima pagina del pannello delle opzioni vi sono le impostazioni generali del programma.

Associazioni
Innanzi tutto è data la possibilità di associare il programma a tutti i tipi di archivi che esso supporta: selezionando uno o più formati, successivamente basterà un doppio click sull'icona che il programma attribuirà loro per poterne leggere il contenuto con ZipGenius.
Inoltre ZipGenius abibnerà anche un menù contestuale. Questo potrà apparire con un clic destro sull'icona di un file associato e offrirà una serie di funzioni, diversa secondo che si tratti di un archivio zip o di un archivio in altri formati.

Lingua
Qui puoi scegliere se usare il programma in italiano o in inglese: questa scelta influenzerà anche la creazione di files autoestraenti e i menù contestuali dei files associati a ZipGenius.

Configurazione di ZipGenius
Scegli la configurazione che ritieni più adatta alla tua dimestichezza con il PC: se scegli la configurazione "NORMALE", sarai sempre guidato dall'Assistente di ZipGenius; se scegli "ESPERTO" potrai anche decidere se e come far intervernire l'Assistente.

Mostra suggerimenti all'avvio
Seleziona questa opzione per leggere i suggerimenti ogni volta che ZipGenius viene avviato.

Click singolo del mouse
Seleziona questa opzione se vuoi sostituire il doppio click con il click singolo per l'attivazione delle funzioni legate alla finestra dei files di ZipGenius.

Invia e-mail tramite ZipGenius Mail
Se usi un programma e-mail non compatibile con il formato MAPI (es.: Opera) oppure se non hai un programma per la posta predefinito, seleziona questa opzione: ZipGenius invierà le e-mail tramite il programma per la posta incorporato.

Queste impostazioni avranno effetto subito dopo aver premuto "OK" nello stesso pannello delle opzioni.


Informazioni utente

In questa pagina puoi inserire alcune informazioni personali che appariranno (se lo vorrai) nella firma che potrai aggiungere ad ogni archivio creato con ZipGenius.

Inserisci innanzi tutto nome, cognome, indirizzo e-mail e (se ne hai una) l'indirizzo della tua homepage; indica, se vuoi, ance il numero di FAX, del cellulare e altre informazioni che ritieni utili per completare la tua firma.

Puoi anche indicare un'immagine che ti rappresenti (per esempio: il logo dell'azienda in cui lavori): questa dovrà necessariamente essere in formato .BMP e dovrà misurare 121x121, altrimenti, oltre a risultare distorta, l'immagine sarà inutilmente ingombrante. Se non indicherai alcuna immagine, ZipGenius 1.4 userà l'immagine predefinita fornita di serie.


Aspetto della finestra

Qui puoi scegliere la configurazione-utente da usare. Se ti ritieni un utente medio o non molto avvezzo all'uso del PC puoi selezionare la configurazione "per tutti gli utenti", con la quale ogni operazione di ZipGenius è assistita dal programma, il quale interverrà per chiederti cosa vuoi fare e spiegarti quali saranno i risultati delle opzioni che sceglierai.

Se invece ti ritieni un utente esperto potrai selezionare la configurazione "per utenti esperti": con questa selezione potrai inoltre stabilire (secondo il tuo livello di conoscenza di ZipGenius e la tua dimestichezza con l'uso del computer) se far intevernire l'assitenza di ZipGenius sempre, solo a richiesta o mai.

Impostazioni finestra.
ZipGenius permette di usare una combinazione di colori carattere/finestra e un tipo di carattere diversi da quelli predefiniti e, inoltre, tale configurazione può essere salvata per poter essere utilizzata ogni volta che si usa ZipGenius.

Alcuni stili sono già definiti ma se hai scaricato la versione STANDARD (file: zg14_std.exe), dovrai scaricare anche il pacchetto Style Pack, che provvederà all'installazione degli stili creati da M.Dev Software; al contrario, se hai scaricato le versioni PLUS oppure SUITE troverai gli stili pronti per l'uso: ti basta selezionarne uno nella casella della sezione "Stile finestra".

Tuttavia puoi creare uno stile nuovo combinando insieme il colore e il tipo di carattere e il colore dello sfondo. Per cambiare il carattere innanzi tutto devi premere "Cambia carattere ": apparirà una finestra in cui potrai scegliere il tipo e la dimensione del carattere che più preferisci; successivamente puoi scegliere il colore del testo e dello sfondo premendo gli appositi tasti, rispettivamente "Colore testo " e " Colore sfondo". Entrambi mostrano un pannello da cui puoi scegliere un colore fra quelli predefiniti in Windows, ma se vuoi scegliere un colore diverso puoi premere il tasto "Altri..." alla base della stessa finestra.

Se lo stile creato è di tuo gradimento puoi assegnargli un nome nella casella a scomparsa degli stili, indicata dal cursore nella figura seguente, e premere il tasto " Aggiungi stile".

Se invece vuoi modificare uno stile esistente, selezioane uno, modificalo seguendo la procedura descritta sopra e premi "Aggiungi stile": ZipGenius ti chiederà se desideri modificare lo stile esistente.

Esportare uno stile.
Premi il tasto "Esporta stile" per far in modo che ZipGenius crei un file zip contenente tutto il necessario per l'installazione dello stile selezionato in un 'altra copia di ZipGenius su un altro PC.

Stili aggiuntivi - inviare un nuovo stile a M.Dev Software.
Il primo Style Pack è disponibile per il download dal sito M.Dev Software per tutti coloro che hanno prelevato la versione STANDARD, mentre è incorporato nelle versioni PLUS e SUITE; altri pacchetti saranno pubblicati successivamente e saranno prelevabili dal sito M.Dev, nei quali sarnno inseriti anche gli stili creati dagli utenti.

Ecco come fare per inviare il proprio stile:

  1. clicca sul tasto "Primo passo "
  2. seleziona l'opzione "Invia stile a M.Dev Software "
  3. ZipGenius creerà automaticamente un nuovo arvchivio zip sul Desktop e lo chiamerà Style_[nome utente].zip, che conterrà i seguenti files: "style.ini" e i files che compongono il tipo di carattere in uso. Il primo file contiene le informazioni sulla combinazione di colori e carattere, mentre i files del tipo di carattere sono necessari, altrimenti altri utenti sprovvisti di quel font potrebbero visualizzare in modo errato il tuo stile
  4. ZipGenius chiederà se ritieni che il contenuto del file zip sia corretto: in caso di risposta negativa interromperà l'azione e ti ricorderà cosa dovrai fare (manualmente) dopo aver modificato il contenuto, altrimenti provvederà a spedire via e-mail l'archivio appena creato a M.Dev Software

Lo stile inviato sarà inserito, quindi, nel primo pacchetto aggiuntivo che verrà rilasciato.

Stili aggiuntivi - inviare uno stile aggiuntivo ad un amico.
Così come è possibile inviare uno stile aggiuntivo a M.Dev, è altrettanto possibile esportare uno stile ed inviarlo ad un amico. La procedura è simile a quella appena descritta:

  1. clicca sul tasto "Primo passo "
  2. seleziona l'opzione " Invia stile ad un amico". E' importante non confondere questa opzione con quella precedente!
  3. ZipGenius creerà automaticamente un nuovo archivio zip sul Desktop come descritto in precedenza, ma in questo caso l'archivio conterrà un file in più: "s_setup.exe". Questo programma serve proprio ad installare gli stili aggiuntivi (vedi più avanti)
  4. ZipGenius chiederà se ritieni che il contenuto del file zip sia corretto: in caso di risposta negativa interromperà l'azione e ti ricorderà cosa dovrai fare (manualmente) dopo aver modificato il contenuto, altrimenti provvederà ad avviare la procedura per l'invio di un messaggio e-mail con il file zip allegato

Stili aggiuntivi - installazione.
 L'installazione degli stili aggiuntivi è semplicissima: basta aprire il file zip contenente lo stile. ZipGenius rileverà il programma di installazione e lo avvierà; al termine dell'installazione lo stile sarà aggiunto alla lista di quelli già installati.


Percorsi

In questa pagina del pannello delle opzioni è possibile indicare alcuni percorsi che potrebbero essere utili al ZipGenius.

Cartella degli archivi preferiti.
E' la cartella in cui sono posti tutti gli archivi che apri più spesso. ZipGenius ti offre la possibilità di scegliere fra alcuni percorsi predefiniti, oppure di indicarne uno di tua preferenza. Cliccando su "OK" ZipGenius userà il percorso prescelto come cartella iniziale su cui saranno aperti tutti i dialoghi di ZipGenius .

Sotto la sezione appena descritta vi è quella dedicata ai programmi esterni per poter creare, decomprimere e modificare archivi in alcuni formati diversi dal formato zip. Per ulteriori informazioni su questa sezione puoi leggere come installare i programmi esterni .


Installare i programmi esterni per la compressione

Installazione programmi esterni

In altra sezione di questa Guida sono spiegati i diversi formati di compressione supportati da ZipGenius, qui quindi vedremo come installare i programmi esterni, senza cui ZipGenius da solo non potrebbe modificarne il contenuto.

Premi il tasto Opzioni [image].
Apparirà il relativo pannello, nel quale devi cliccare su "Percorsi". Il pannello delle opzioni muterà come di seguito:

Seleziona il formato per cui vuoi installare il programma esterno (.ARJ nell'esempio in figura) e clicca su "Cerca": vedrai apparire un dialogo in cui dovrai indicare la posizione del programma (in questo caso arj.exe: osserva la figura seguente).

Fatto ciò, clicca su "Aggiungi": vedrai il percorso del programma selezionato nella casella denominata "Percorso:".

Adesso puoi cliccare su "Salva" per far in modo che ZipGenius salvi quel percorso fra le altre impostazioni.

ATTENZIONE! Se premi "OK" prima di aver premuto "Salva", il percorso non sarà memorizzato!

"Da quale sito...".
Questo bottone apre il tuo browser predefinito su una pagina del sito M.Dev Software riservata ai programmi esterni, nella quale troverai informazioni sui siti da cui puoi prelevare i programmi esterni richiesti da ZipGenius; per alcuni di essi potrà persino esservi la possibilità di scaricarli direttamente dal sito M.Dev Software.

Argomenti correlati
 Archivi supportati da ZipGenius


Creare un nuovo archivio.

Questa funzione è applicabile ai seguenti formati:

  • Zip
  • Cab
  • LZH/LHA, ARJ, ARC, TAR, GZIP, ZOO tramite programma esterno
  • Pak

1) Premere il tasto "Nuovo" .

Configurazione NORMALE.
Apparirà l'assistente di ZipGenius: basterà perciò seguire le istruzioni riportate dall'assistente, il quale permetterà di inserire subito dei files nel nuovo archivio.

Configurazione ESPERTO.
Apparirà una finestra di dialogo in cui sarà possibile scegliere il nome e la posizione in cui creare il nuovo archivio.

ATTENZIONE! Un archivio senza files non può esistere, quindi è bene premere il tasto Aggiungi files per aggiungere files all'archivio appena creato. Tuttavia se nelle opzioni hai impostato l'intervento dell'assistente a richiesta, questi ti ricorderà questo particolare e chiederà se desideri aggiungere files immediatamente.


Aggiungere files

Perché un archivio sia creato è necessario aggiungere uno o più files a questo, altrimenti - sebbene sia stato premuto il tasto " Nuovo" - l'archivio non sarà creato.

La procedura è diversa secondo la configurazione scelta.
In modalità NORMALE le operazioni sono guidate dall'Assistente di ZipGenius, il quale provvederà a spiegare passo per passo tutte le operazioni possibili e le opzioni disponibili; in modalità ESPERTO invece l'Assistente interverrà secondo le impostazioni effettuate nel pannello delle opzioni, quindi se avrai richiesto il suo intervento "sempre", ZipGenius si comporterà come se fosse in modalità normale, mentre se avrai deciso di non farlo intervenire, dovrai procedere come descritto di seguito:

Selezione files
Apparirà il dialogo di ZipGenius: in questo potrai selezionare uno o più files di qualsiasi tipo, quindi premi il tasto "Aggiungi ".

Opzioni di compressione
In questa finestra potrai selezionare alcune opzioni per la compressione:

  • Livello di compressione: i livelli disponibili sono cinque. Il primo serve soltanto ad archiviare i files senza ridurne le dimensioni originali e costituisce il metodo più veloce; il secondo e il terzo offrono efficienza di compressione e velocità medie; il quarto è il livello che offre il maggior livello di compressione e la minor velocità di esecuzione. N.B.: con i primi quattro livelli ZipGenius aggiunge i files del tipo GIF, JPG, TAR, GZ, ZIP, ARJ, ZOO senza comprimerli (come se selezionasse automaticamente il primo livello). Per tentare di comprimere anche questi tipi di files occorre selezionare il quinto livello, che costringe ZipGenius a tentare di comprimere questi files già compressi per natura.
  • Cancella files dopo l'inserimento: se vuoi che i files originali siano rimossi dalla loro posizione dopo averli aggiunti ad un archivio, puoi selezionare questa opzione: ZipGenius aggiungerà i files all'archivio e li cancellerà dalla posizione originale.
  • Includi intero percorso: seleziona questa opzione per aggiungere ogni file con l'intero percorso originale (ad esclusione della lettera dell'unità). Quando estrarrai questi files con l'opzione "Usa percorsi salvati" ZipGenius ricreerà i percorsi originali all'interno della cartella di destinazione.
  • Aggiungi sottocartelle: questa opzione è disponibile solo se si sta aggiungendo il contenuto di una intera cartella, dato che provvede ad aggiungere il contenuto di tutte le sottocartelle contenute in quella prescelta. ATTENZIONE! se estrarrai questi files con l'opzione "Usa percorsi salvati", ZipGenius provvederà a ricreare la cartella archiviate e tutte le sue sottocartelle, con il rischio di saturare il disco rigido nel caso la cartella archiviata fosse di dimensioni generose.
  • Aggiungi files nascosti: questa opzione permette di inserire in un archivio anche i files nascosti.
  • Aggiungi files solo se hanno l'attributo "Archivio": questa opzione permette di inserire in un archivio soltanto i files dotati dell'attributo "archivio", escludendo, quindi i files di sistema.
  • Azzera l'attributo "Archivio": con questa opzione ZipGenius rimuove l'attributo "Archivio" ai files che sta per aggiungere ad un archivio.
  • Salva i nomi in formato DOS : prima di Windows 95 i files non poevano avere nomi di lunghezza maggiore di otto caratteri più tre per l'estensione dopo il punto (il formato definito "8.3"); ancora oggi questa opzione potrebbe risultare utile per creare archivi compatibili con il DOS in modalità reale (disponibile fino alla pubblicazione di Windows Millennium Edition) e con Windows 3.x. In generale questa opzione è obsoleta ed è stata mantenuta solo per offrire retrocompatibilità.

Inoltre è possibile scegliere il TIPO DI INSERIMENTO:

  • Normale
  • Aggiorna files esistenti: se l'archivio contiene files con lo stesso nome di quelli che stanno per essere aggiunti, ZipGenius sostituisce quelli archiviati con quelli da archviare solo se questi ultimi sono più recenti.
  • Aggiungi e aggiorna: ZipGenius aggiorna i files archiviati con i files più recenti e aggiunge i files non già presenti nell'archivio.


Cancellare files da un archivio

Attenzione! Usare questa funzione con molta cautela!

Questa funzione è disponibile direttamente per gli archivi ZIP, CZIP, PAK e CAB, mentre per tutti gli altri sono necessari appositi programmi esterni .

Per cancellare uno o più files da un archivio, oppure per distruggere un intero archivio, è sufficiente premere il tasto " Cancella" [image].

Configurazione NORMALE

Il tasto "Cancella" e la voce relativa nel menù rapido di ZIpGenius si comprteranno così:

  1. se uno o più files nella lista sono selezionati il programma chiederà se si desidera cancellare i files selezionati;
  2. se nessun file è selezionato il programma chiederà se si desidera rimuovere tutti i files dall'archivio.

Per distruggere un archivio con questa configurazione è necessario premere il tasto "Primo passo" e selezionare l'opzione "Distruggi archivio".

Configurazione ESPERTO

Il tasto "Cancella" è diviso in due sezioni. Cliccando sull'icona il tasto assumerà diversi comportamenti:

  1. se uno o più files nella lista sono selezionati il programma chiederà se si desidera cancellare i files selezionati;
  2. se nessun file è selezionato il programma chiederà se si desidera rimuovere tutti i files dall'archivio.

Cliccando sulla sezione del tasto con la freccia nera o selezionando la voce relativa nel menù rapido, apparirà un sottomenù con le seguenti opzioni:

  1. Cancella tutti i files - cancella tutti i files da un archivio, lasciandolo virtualmente pronto per l'inserimento di altri files. Se un archivio senza files verrà chiuso, questo si distruggerà automaticamente.
  2. Cancella solo i files selezionati - cancella solo uno o più files selezionati.
  3. Distruggi archivio - cancella l'archivio integralmente.


Firmare un archivio

Firmare un archivio (ZGSignTM )

Fin dalla precedente edizione, ZipGenius consente di creare una "firma" da inserire negli archivi zip; questa altro non è che un file aggiuntivo riportante il nome, l'indirizzo e-mail del creatore dell'archivio, una breve descrizione e la data e l'ora della creazione della firma.

A partire da questa edizione è possibile anche inserire l'indirizzo della propria pagina Web e un'immagine in formato .BMP di dimensioni 121x121 pixel; inoltre, la stesse informazioni possono essere inserite nell'archivio sotto forma di commento zip standard, cioé visibile anche da altri programmi concorrenti. La firma creata con ZipGenius, infatti, è visualizzabile solo da ZipGenius 1.3.x o superiore.

Una firma creata con ZipGenius 1.4, però, non può essere visualizzata da ZipGenius 1.3 o da ZipGenius Evoluzione giacché nella versione 1.4 del programma è stato usato un sistema diverso rispetto alle edizioni passate; per creare una firma compatibile con le versioni precedenti del programma è necessario selezionare l'opzione Compatibile con ZipGenius 1.3, grazie alla quale la firma verrà creata usando il vecchio metodo; purtroppo il vecchio metodo non consente di inserire l'indirizzo di una pagina Web, nè di inserire un'immagine. Dalla prossima edizione (ZipGenius 1.5) la compatibilità con la versione 1.3 non sarà più assicurata.

Per creare una firma occorre premere il tasto [image] Firma.

Dopo aver creato la firma, ZipGenius aggiungerà il file infopak.zgp (o il file nomearchivio.zip.info se si è scelta l'opzione di retrocompatibilità) all'archivio aperto, ma questo non apparirà nella lista dei files; apparirà, invece, se si aprirà l'archivio con altri programmi che non supportano la tecnologia ZGSignTM.

Quando un altro utente di ZipGenius aprirà l'archivio firmato, il programma riconoscerà il file della firma e mostrerà questa automaticamente. Dalla stessa finestra si potrà, poi, mandare un messaggio e-mail o visitare la home page dell'autore dell'archivio: basterà cliccare su l'uno o sull'altro.

Le informazioni personali (nome, e-mail, pagina web, immagine e altro) possono essere inserite nella pagina "Informazioni utente " delle opzioni di ZipGenius, così queste saranno inserite automaticamente ogni volta che si desidera creare una firma.


File ReadMe.txt

Quasi tutti gli archivi zip reperibili in Rete contengono un file chiamato "Readme.txt" in cui è possibile trovare avvisi e informazioni varie sul contenuto di quell'archivio. ZipGenius facilita l'operazione di lettura di questo file tramite il tasto [image] ReadMe, che estrarrà temporaneamente il file e lo mostrerà nel visualizzatore interno .

La presenza di tale file in un archivio sarà rilevata automaticamente dal programma tramite il messaggio "README" nella barra di stato.

Per alcuni tipi di archivio (diversi dal formato zip) questa funzione non è supportata, quindi il tasto "ReadMe" resterà disabilitato.


Installazione di programmi

Gli archivi zip sono spesso usati per distribuire programmi attraverso Internet. In questi archivi si trova generalmente il file "setup.exe" che serve ad avviare l'installazione del programma zippato; ZipGenius è in grado di rilevare questo file e di avviare l'installazione del programma a quello collegato.

Se il file "setup.exe" è individuato, il programma ne darà comunicazione nella barra di stato (messaggio: "SETUP") e abiliterà l'apposito tasto [image] Installa.

ZipGenius estrarrà tutti i files contenuti nell'archivio, rispettandone l'eventuale ripartizione in sottocartelle, e avvierà automaticamente l'installazione; comparirà un messaggio che inviterà a premere il tasto "OK" solo al termine dell'installazione: premendolo anticipatamente, infatti, potrebbero residuare alcuni dei files estratti temporaneamente, mentre seguendo quel consiglio, ZipGenius provvederà a rimuovere tutti i files estratti per consentire l'operazione.

Questa funzione non è disponibile per tutti i formati di archivio supportati: per i formati per cui non è disponibile tale funzione, il tasto "Installa" resterà disabilitato.


Rinominare un file in archivio

ZipGenius 1.4 ti dà la possibilità di cambiare il nome dei files archiviati in formato zip.

Basta selezionarne uno e cliccare con il tasto destro del mouse, quindi dal menù dovrai scegliere la voce "Rinomina". Potrai rinominare il file come già fai con Esplora Risorse.


Anteprima di un file archiviato

ZipGenius consente di vedere un file compresso in anteprima. Per far ciò, estrae il file selezionato in una cartella temporanea, lo mostra e, infine, lo cancella.

Tuttavia non tutti i files possono essere mostrati in anteprima: ciò dipende sia dal tipo di file selezionato, sia dalla configurazione scelta per il programma.

N.B.: è possibile vedere in anteprima un solo file per volta, quindi se selezioni più di un file, non potrai attivare la funzione "Anteprima".

Configurazione "Normale"
Cliccando su "Anteprima" o selezionando la relativa voce del menù rapido del programma, ZipGenius tenta di aprire il file selezionato con il programma associato a quel tipo di file; se nessun programma è associato, il programma tenterà di mostrarne il contenuto tramite il visualizzatore interno.

Configurazione "Esperto"
In questa configurazione il tasto "Anteprima" è diviso in due sezioni: cliccando sulla sezione con l'icona il risultato sarà identico a quanto descritto per la configurazione "NORMALE"; clicando sulla freccia nera apparirà, invece, un menù dal quale sarà possibile costringere ZipGenius a tentare di mostrare il file con il programma associato, oppure di mostrarlo direttamente con il visualizzatore interno.

Se il file selezionato è un archivio zip (zip concatenati) verrà attivata la funzione "ZipList".

Il visualizzatore interno
Tramite la finestra di questo sarà possibile leggere (o tentare di leggere) i files in formato testuale; se un documento contiene l'indirizzo di una pagina Web o un'indirizzo e-mail, il visualizzatore è in grado di riconoscerli e possono essere usati cliccando direttamente su essi.


Lista Zip

Molti archivi zip contengono altri archivi zip, costituendo così quelli che vengono definiti zip concatenati. ZipGenius permette di leggere il contenuto di questi archivi zip nella stessa finestra in cui è stato aperto l'archivio "maggiore", cioè quello che si è aperto per primo. Ogni volta che farai doppio click sul nome di uno zip concatenato, il programma lo estrarrà, ne mostrerà il contenuto nella finestra principale (permettendoti di usare tutte le funzioni anche sugli zip concatenati: sarà solo impedito l'inserimento di files e la firma) e riporterà il nome di quell'archivio nella lista che apparirà lateralmente. Il primo nome di file nella lista è quello dell'archivio maggiore, che avrai aperto con il tasto "Apri" o in tutti gli altri modi descritti in questa Guida, mentre tutti gli altri saranno i nomi dei files zip concatenati e già visualizzati; con questo sistema potrai saltare da un archivio zip all'altro senza doverlo estrarre nuovamente, poiché i files menzionati nella lista non saranno cancellati finché non sarà chiuso definitivamente l'archivio maggiore.

Esempio:

L'archivio maggiore "Maggiore.zip" è stato aperto...

... contiene il file "zip1.zip"; clicchiamo due volte su questo...

... e il suo nome è aggiunto alla lista. A sua volta esso contiene un altro zip: ripetiamo l'operazione...

... così anche "zip2.zip" è stato aggiunto alla lista. Possiamo tornare a leggere il contenuto di uno degli archivi elencati facendo doppio click sul nome in elenco.

Premendo il tasto [image] "Lista Zip" apparirà semplicemente l'elenco dei files zip concatenati aperti fino a quel momento. L'elenco, infatti, può essere ridimensionato o chiuso per avere maggior spazio a disposizione nella finestra.


Creare files autoestraenti (SFX)

I files zip possono essere aperti generalmente solo con programmi come ZipGenius o simili, quindi chi riceve uno zip e non ha uno di questi programmi installato si trova in difficoltà.

E' giusto, quindi, far sì che il destinatario di un archivio zip sia messo in grado di poter leggere l'archivio, anche se egli non dispone di ZipGenius (o altri simili): per far ciò è possibile creare archivi autoestraenti, comunemente chiamati SFX. Questi altro non sono che archivi zip ai quali è stato connesso un piccolo programma contenente l'algoritmo necessario per eseguire l'estrazione dei files.

ZipGenius può creare due tipi di SFX:

  1. il primo SFX è definito standard, poiché provvede alla semplice estrazione dei files contenuti in esso;
  2. il secondo è definito autoinstallante, giacché può estrarre tutti i files e avviare il file setup.exe, in genere corrispondente alla procedura di installazione di un programma.

Per avviare la procedura di creazione di un SFX basta premere il tasto [image] SFX: apparirà l'assistente di ZipGenius che ti guiderà nella creazione e personalizzazione di un file SFX. Esaminiamo i vari passi secondo il loro ordine...

Messaggio di avvio
Puoi far apparire un messaggio quando il destinatario farà doppio clic sul tuo file SFX. Puoi scegliere fra tre tipi diversi di messaggio: Standard (per dare semplici comunicazioni), Informazioni (per dare informazioni importanti - il messaggio avrà i tasti "OK" e "Annulla") e Richiesta (per porre una richiesta all'utente - il messaggio avrà i tasti "Sì" e "No"). Se non vuoi mostrare alcun messaggio lascia in bianco l'apposita casella e premi Avanti.

Titolo dell'archivio
Indica il titolo che dovrà apparire nella finestra del tuo file SFX.

Icona dell'archivio
Qui puoi scegliere se far apparire l'icona predefinita per i files SFX, oppure se usare un'icona personalizzata; in quest'ultimo caso puoi scegliere premendo il tasto "Sfoglia" e caricando un file .ICO o files .EXE e .DLL contenenti icone. Se il file caricato sarà un .EXE o una .DLL puoi scorrere la lista delle icone in essi contenuti.

Se il file zip contiene un programma di installazione (setup.exe), ZipGenius chiederà se si desidera creare un SFX autoinstallante: se selezionerai "Sì", non ci saranno altri passi e l'operazione sarà ultimata automaticamente.
Se invece selezionerai "No" o se il file zip non contiene un programma d'installazione, accederai al passo successivo.

Esecuzione di un file al termine
Se lo desideri, puoi fare in modo che il file SFX esegua uno dei files estratti.

Altre opzioni
Questo è l'ultimo passo. Qui puoi scegliere le altre impostazioni per il file SFX da creare:

    • Destinazione predefinita - indica il percorso che ritieni ideale per l'estrazione dei files. Questo apparirà nella finestra dell'SFX.
    • Permetti di disattivare l'esecuzione automatica... - permetti al destinatario di disabilitare l'esecuzione del file indicato nel passo precedente.
    • Se il file da estrarre è già esistente... - scegli il comprtamento del file SFX nei confronti di files già esistenti.
    • Nascondi la scelta del tipo di sovrascrittura - puoi fare in modo che il destinatario dell'SFX non modifichi l'opzione precedente.
    • Consenti all'utente di modificare la lista... - puoi permettere all'utente di selezionare i files da estrarre. Normalmente sono estratti tutti i files.
    • Mostra messaggio di conferma estrazione - al termine dell'estrazione apparirà un messaggio di conferma.

A questo punto dovrai cliccare "Avanti" per avviare la creazione del file autoestraente.


Password

Puoi proteggere il contenuto di un archivio ZIP con una password: ciò non significa, però, che non si possa leggere il contenuto dell'archivio, poiché la password imedisce soltanto che i files siano estratti dall'archivio.

ZipGenius 1.4 può proteggere un archivio con la password, ma questa funzione è stata solo mantenuta per motivi di compatibilità con le versioni precedenti e con i programmi concorrenti, poiché ZG offre il sistema CryptoZip, mediante cui gli archivi zip vengono criptati e diventa impossibile leggerne il contenuto se non si conosce la chiave corretta.


Antivirus

Avere un buon antivirus è sempre necessario al giorno d'oggi, perciò anche ZipGenius si è dotato di questa nuova possibilità: può far esaminare gli archivi di ogni formato dall'antivirus installato sul tuo PC.

Se questa funzione è selezionata nelle opzioni, viene avviata automaticamente ogni volta che si vuole aprire un archivio.

Nella finestra delle opzioni, clicca "Impostazioni avanzate" nella barra laterale e seleziona l'opzione "Esamina archivi con il seguente antivirus prima di aprirli".

La casella di testo sottostante sarà abilitata e potrai cancellare l'esempio riportato, sostituendolo con l'appropriato percorso completo dell'antivirus e i parametri di funzionamento da riga di comando; per conoscere quali parametri usare è consigliabile consultare la Guida dell'antivirus installato sul tuo PC.

Esempio:
supponendo che l'antivirus installato sia InoculateIT PE, e supponendo che il suo percorso sia C:\Programmi\InoculateIT PE\Vet98.exe, nella casella del percorso potrai scrivere la seguente riga di comando:

"C:\Programmi\InoculateIT PE\Vet98.exe" /display=progress %s

Il parametro "%s " è necessario, in quanto ZipGenius provvederà a sostituirlo con il nome del file-archivio che stai tentando di aprire, perciò (sempre secondo le istruzioni di ogni antivirus) dovrai inserirlo dopo il percorso del programma antivirus (generalmente subito dopo di esso).

Quando l'attività dell'antivirus sarà finita ZipGenius chiederà se sono stati trovati virus: clicca "NO" per proseguire con l'apertura dell'archivio.

N.B.: Computer Associates, produttore di InoculateIT PE non è legata in alcun modo a M.Dev Software. L'unica ragione per cui è citato questo prodotto è che anche InoculateIt PE è un ottimo prodotto gratuito, con aggiornamenti gratuiti , ossia segue la stessa filosofia di ZipGenius.


CryptoZip: gli archivi Zip criptati

Una delle nuove e più interessanti caratteristiche di ZipGenius 1.4 è la possibilità di crittografare un archivio ZIP; è vero che il formato zip stesso prevede una protezione dei files in questo formato tramite una password, ma è anche vero che si stanno diffondendo piccoli programmi in grado di recuperare (in maniera più o meno veloce) la password messa a protezione di un file zip.

ZipGenius oggi introduce una protezione diversa che può essere usata congiuntamente o in sostituzione alla password: la crittografia. E' possibile infatti "criptare" qualsiasi archivio zip con una chiave numerica tripla, riuscendo così a creare una combinazione su 281.474.976.710.656 disponibili (cioé: 655363).

Questa funzione è accessibile direttamente dal tasto [image] per gli utenti che hanno selezionato la configurazione "ESPERTO", mentre per gli altri tale funzione è accessibile dall'Assistente Primo Passo.

Dopo aver attivato questa funzione, apparirà la seguente finestra:

Per criptare l'archivio occorre inserire tre valori compresi fra 0 e 65535 nelle tre caselle mostrate nella figura, oppure è possibile lasciar scegliere a ZipGenius questi tre codici in modo casuale; la chiave composta dai tre valori può poi essere salvata in una lista criptata: per far ciò basta selezionare la casella "Aggiungi alla lista delle chiavi".

Per avviare la crittografia devi cliccare su "OK" e ZipGenius creerà un nuovo file dal nome identico a quello originale, ma con l'estensione .CZIP (Es.: Test.zip -> Test.czip).

ATTENZIONE! Una volta criptato, un archivio può essere aperto solo se si usa la stessa chiave con cui è stato codificato, altrimenti ZipGenius non mostrerà alcun file nella sua finestra. E' vivamente consigliabile, quindi, salvare la chiave numerica nella lista apposita, affinché si possano evitare eventuali perdite di dati o documenti causati dallo smarrimento della chiave numerica. Il salvataggio della chiave puà essere automaticamente effettuato ad ogni crittografia se si seleziona la relativa casella nella pagina "Impostazioni avanzate" del pannello delle opzioni.

La lista stessa è criptata al fine di garantire la massima sicurezza.

Questa funzione è disponibile soltanto a partire dalla versione attuale di ZipGenius (1.4): gli utenti di versioni precedenti del programma possono prelevare DeCryptoZip dal sito M.Dev: questa utility permette di decodificare gli archivi CryptoZip e di aprire automaticamente il file zip che verrà ricostruito; gli utenti di altri programmi concorrenti, invece, non potranno usare DeCryptoZip poiché il programma provvede a verificare l'installazione di una qualsiasi versione di ZipGenius (dalla versione 1.3 in poi).

Per decriptare un archivio criptato basta premere nuovamente il tasto "Cripta" e il programma avviserà che l'archivio attualmente aperto è già criptato e se si desidera decriptarlo: clicca "Sì" e ZipGenius ti chiederà di inserire la chiave numerica dell'archivio .czip. A quel punto avrai un normalissimo archivio zip visibile con tutti i programmi appositi. Se non ricordi la chiave numerica, puoi sempre cercarla nella lista delle chiavi, a patto però che tu l'abba inserita in quella lista con l'opzione "Aggiungi alla lista delle chiavi numeriche"; per poter accedere alla lista basta cliccare l'apposito tasto "Seleziona chiave dalla lista": la prima volta ti sarà chiesto di digitare una password (e di confermarla), che da quel momento in poi non potrà più essere modificata. Se qualcuno tentasse di aggirare la password, ZipGenius provvederà a cancellare il file della lista di chiavi. E' opportuno, quindi, stampare la lista o salvarla su un floppy disk: la finestra della lista di chiavi disponi due pulsanti riservati a queste operazioni.

N.B.: quando un archivio .czip è aperto, ZipGenius lo tratta come se fosse un archivio zip standard, perciò sarà possibile modificare il contenuto dello stesso e usare tutte le funzioni che il programma mette a disposizione per gli archivi zip standard; l'unica differenza consiste nel fatto che ZipGenius rileverà eventuali modifiche e avvertirà che è necessario criptare nuovamente l'archivio, altrimenti si potrebbero avere un file criptato e uno decriptato temporaneo (usato da ZipGenius per la visualizzazione dei files) dal contenuto diverso.


Linea di comando

ZipGenius 1.4 ha esteso le funzionalità della linea di comando. Ecco come usare ZipGenius con questo sistema.

Ogni comando ha la propria sintassi.

Elenco comandi

addfile
addfold
extract
delete
destroy
print
export
mail
sfx
crypt
decrypt

-addfile (Sintassi: zg.exe -addfile archivio file1 [file2 ... fileN] [-0149BMPHAZ])

Aggiunge files ad un archivio.

0: Nessuna compressione.
1: Compressione minima.
4: Compressione media.
9: Compressione massima.
B: Compressione brutale.
M: Sposta i files dopo l'inserimento.
P: Salva il percorso originale di ogni file.
H: Aggiunge anche i files nascosti.
A: Aggiunge solo i files con l'attributo "archivio".
Z: Azzera l'atributo "archivio" nei files da inserire.

Esempio - aggiungere il file test.txt all'archivio arctest.zip, usando il livello massimo di compressione e salvando il percorso originale del file:
zg.exe -addfile arctest.zip test.txt -9P

-addfold (Sintassi: zg.exe -addfold archivio cartella [-0149BRMPHAZ])

Aggiunge una cartella ad un archivio.

0: Nessuna compressione.
1: Compressione minima.
4: Compressione media.
9: Compressione massima.
B: Compressione brutale.
R: Aggiunge anche le sottocartelle.
M: Sposta i files dopo l'inserimento.
P: Salva il percorso originale di ogni file.
H: Aggiunge anche i files nascosti.
A: Aggiunge solo i files con l'attributo "archivio".
Z: Azzera l'atributo "archivio" nei files da inserire.

Esempio 1 - aggiungere la cartella C:\Test e le sue sottocartelle all'archivio arctest.zip:
zg.exe -addfold arctest.zip c:\test\*.* -R

Esempio 2 - aggiungere tutti i files .DOC della cartella C:\Test all'archivio arctest.zip:
zg.exe -addfold arctest.zip c:\test\*.doc

-extract (Sintassi: zg.exe -extract archivio [file1 file2 ... fileN] [-APD] [|"Destinazione"])

Estrae i files da un archivio.

A: Estrae tutti i files.
P: Usa i percorsi salvati.
D: Apre la cartella di destinazione.

La cartella di destinazione può essere indicata come ultimo parametro.

Esempio 1 - estrarre tutti i files dall'archivio arctest.zip nella cartella C:\Test usando i percorsi originali:
zg.exe -extract arctest.zip -AP |c:\test

Esempio 2 - estrarre tutti i files .DOC dall'archivio arctest.zip nella cartella C:\Test:
zg.exe -extract arctest.zip *.doc |c:\test

-delete (Sintassi: zg.exe -delete archivio [file1 file2 ... fileN]

Cancella files da un archivio

Esempio 1 - per cancellare tutti i files dall'archivio arctest.zip:
zg.exe -delete arctest.zip *.*

Esempio 2 - per cancellare il file test.txt dall'archivio arctest.zip:
zg.exe -delete arctest.zip test.txt

Esempio 3 - per cancellare tutti i files .DOC dall'archivio arctest.zip:
zg.exe -delete arctest.zip *.doc

-destroy (Sintassi: zg.exe -destroy archivio)

Distrugge un archivio.

Esempio: zg.exe -destroy arctest.zip

-print (Sintassi: zg.exe -print archivio)

Stampa la lista dei files di un archivio.

Esempio: zg.exe -print arctest.zip

-export (Sintassi: zg.exe -export archivio formato)

Esporta la lista dei files di un archivio nel formato indicato. Indicare il formato dopo il nome del file-archivio:

HTML: esporta la lista in un pagina Web.
DOC: esporta la lista in un documento di Word.
CSV: esporta la lista in un documento con valori separati da virgole.
XLS: esporta la lista in un foglio di Excel.
XML: esporta la lista in un file XML.
TXT: esporta la lista in un documento di testo.

Esempio 1 - esportare la lista dei files dell'archivio arctest.zip in un pagina Web:
zg.exe -export arctest.zip HTML

Esempio 2 - esportare la lista dei files dell'archivio arctest.zip in un documento di Word:
zg.exe -export arctest.zip DOC

-mail (Sintassi: zg.exe -mail archivio1 [archivio2 ... archivioN])

Spedisce uno o più archivi via e-mail.

Esempio: zg.exe -mail arctest.zip

-sfx (Sintassi: zg.exe -sfx archivio)

Crea un archivio autoestraente da un archivio zip.

Esempio: zg.exe -sfx arctest.zip

-crypt (Sintassi: zg.exe -crypt archivio chiave1 chiave2 chiave3)

Crea un archivio zip criptato (CZIP) da un archivio zip. Le tre chiavi numeriche devono essere tre valori fra 0 e 65535.

Esempio: zg.exe -crypt arctest.zip 23909 61616 12301

-decrypt (Sintassi: zg.exe -decrypt archivio chiave1 chiave2 chiave3)

Crea un archivio zip da un archivio zip criptato (CZIP). Le tre chiavi numeriche devono essere tre valori fra 0 e 65535.
N.B.: se i tre valori immessi non corrispondono a quelli usati per criptare l'archivio, quest'ultimo sarà decriptato ugualmente ma sarà illeggibile.

Esempio: zg.exe -decrypt arctest.zip 23909 61616 12301


Esportare la lista dei files

ZipGenius 1.4 offre la possibilità di esportare la lista dei files inseriti in qualsiasi tipo di archivio supportato dal programma. Tale lista può essere esportata in sei modi diversi:

  • HTML - ZipGenius crea un file HTML (una pagina Web).
  • DOC - ZipGenius crea un file in formato compatibile con Word.
  • XLS - ZipGenius crea un file in formato compatibile con Excel.
  • CSV - ZipGenius crea un file leggibile dalla maggior parte dei databases esistenti (valori separati da virgole).
  • XML - ZipGenius crea un file XML.
  • TXT - ZipGenius crea un file visualizzabile con il Blocco Note di Windows.

Configurazione NORMALE

  1. Premere "Primo passo ";
  2. selezionare il tipo di esportazione (es.: "Esporta lista in HTML ");
  3. indicare in quale cartella creare il file con la lista.

Configurazione ESPERTO

Gli utenti esperti hanno a disposizione il tasto [image]. Se nelle opzioni non è stato indicato un formato di esportazione preferito, premendo il tasto apparirà un menù con tutti i formati di esportazione, altrimenti il tasto "Esporta" sarà diviso in due: premendo la sezione con l'icona la lista sarà esportata nel formato preferito indicato nelle opzioni, mentre premendo la sezione con la freccia nera apparirà il menù da cui scegliere il formato.
Fatto ciò, basterà indicare in quale cartella ZipGenius dovrà creare il file nel formato prescelto.


Funzioni di Backup

Sebbene Windows a 32 bit sia diventato sempre più stabile rispetto alla prima edizione del 1995, ancora oggi è fondamentale creare delle copie di sicurezza di parti vitali del sistema, come - ad esempio - la cartella "Documenti", che nel tempo è stata sempre più valorizzata come il centro di raccolta di tutti i documenti prodotti dalle applicazioni di Windows 9x, e in Windows ME e 2000 è addirittura la prima cartella sul Desktop.

Da alcune ricerche, però, risulta che ben pochi sono gli utenti abituati ad eseguire regolari backup dei propri documenti o dei files di sistema, e le cause generalmente sono due:

  1. eccessiva complessità d'uso dei programmi a questo preposti;
  2. timore di compiere azioni in grado di danneggiare il sistema.

ZipGenius 1.4 rimuove entrambe queste cause e da oggi offre un'ampia scelta di backup predefiniti, più la possibilità di fare il backup di una cartella a scelta.

"Comprimi files":
clicca qui per selezionare o meno questa opzione: se selezionata i files che saranno coinvolti nel backup saranno compressi al livello massimo e l'operazione risulterà più lenta; in compenso l'archivio che sarà generato occuperà meno spazio sul disco.

"Cartella Documenti":
esegue il backup della cartella documenti e genera il file Documents.zip.

"Cartella di Windows":
esegue il backup della cartella in cui è installato Windows e genera il file Windows.zip. ATTENZIONE: il file generato potrebbe avere dimensioni superiori a 300 Mb.

"Cartella di sistema":
esegue il backup della cartella SYSTEM di Windows e genera il file System.zip. ATTENZIONE: il file generato potrebbe avere dimensioni superiori a 200 Mb.

"Files del Registro di Windows":
esegue una copia di sicurezza del registro di configurazione. ZipGenius copierà i files "system.dat", "user.dat", "system.ini" e "win.ini" in un archivio ".cab" compatibile con "ScanReg ", così a poter recuperare interamente il registro di configurazione, l'utilità di controllo e ripristino del registro incorporata in Windows 98. Il file generato sarà rb100.cab e sarà posizionato nella cartella SYSBCKUP di Windows (es.:"c:\windows\sysbckup").

"Messaggi di Outlook Express":
esegue una copia di sicurezza dei messaggi di tutte le "identità" di Outlook Express 5 e genera il file OE5_bak.zip.

"Rubrica di Windows":
esegue una copia di sicurezza della Rubrica attualmente in uso da Windows e genera il file WAB_bak.zip.


Scan + Zip

Grazie a questa funzione, ZipGenius ha la possibilità di aggiungere immagini ad un archivio direttamente dallo scanner, da una fotocamera digitale o da qualsiasi periferica che utilizzi i drivers TWAIN.

Basta premere il tasto [image]. Il programma chiederà di selezionare una delle periferiche TWAIN rilevate e, fatto ciò, apparirà la seguente finestra:

Per avviare l'acquisizione di un'immagine è sufficiente premere il tasto "ACQUISISCI": il programma verificherà la presenza di altri file nell'archivio e proporrà un nome per il file che sarà generato dopo l'acquisizione. Se vuoi potrai modificare il nome proposto con uno di tuo gradimento . Es.: "Piazza di Spagna" -> il file generato sarà "Piazza di Spagna.bmp".

Terminata l'acquisizione è necessario premere "AGGIUNGI " per inserire l'immagine nella lista dei files da inserire nell'archivio; al contrario, se già vi sono delle immagini e si desidera rimuoverne qualcuna, basta selezionarne una e premere il tasto "RIMUOVI".

E' possibile usare lo zoom per ingrandire o rimpicciolire la visualizzazione dell'immagine: basta selezionare uno dei valori alternativi a "1:1", che è quello predefinito, tramite cui l'immagine è mostrata così come è stata acquisita. ATTENZIONE: lo zoom non modifica le dimensioni reali dell'immagine.

Per completare l'operazione e inserire le immagini acquisite, basterà chiudere la finestra dalla "x" in alto a destra: il programma chiederà se si desidera inserire tutte le immagini acquisite. Se si risponderà "NO", le immagini non verranno compresse.

ATTENZIONE: le immagini acquisite sono trasformate in file ".bmp" e compressi usano il livello massimo di compressione.


ZGTools

Rispetto alla versione precedente, ZipGenius 1.4 si caratterizza per la presenza degli ZGTools, cioè piccoli programmi esterni in grado sia di collaborare con ZipGenius, sia di lavorare indipendentemente da questo; questi sono inclusi soltanto nella distribuzione SUITE di ZipGenius, quindi chi fosse in possesso delle edizioni STANDARD o PLUS può scaricarli singolarmente dal sito M.Dev Software.

Gli ZGTools attualmente disponibili da M.Dev Software sono i seguenti:

    • Cutter
    • DeCryptoZip
    • Time To Get!

Come detto, questi sono prodotti da M.Dev Software, ma altri sviluppatori possono creare ZGTool installabili in ZipGenius 1.4 (vedi ).

Per installare uno ZGTool l'utente non deve far niente, dato che ognuno di essi (esclusi quelli prodotti da M.Dev Software, compresi quelli non distribuiti con le edizioni STANDARD e PLUS di ZipGenius) dispone del proprio programma di installazione, che provvede ad aggiungere uno o più comandi relativi allo ZGTool nel menù "Strumenti" di ZipGenius, così come mostrato nella seguente figura:

ZipGenius cerca e installa nuovi ZGTools ogni volta che viene avviato, pertanto è bene installare nuovi ZGTools quando ZipGenius non è in esecuzione.


Creare uno strumento esterno (ZGTools)

L'edizione SUITE di ZipGenius comprende anche i cosidetti ZGTools, cioè piccoli programmi che possono sia funzionare indipendentemente che unitamente al programma principale. Questi programmi sono prodotti da M.Dev Software, tuttavia anche sviluppatori terzi possono creare altri ZGTools.

Perchè uno ZGTool sia comandabile da ZipGenius è opportuni che "comunichi" la propria presenza tramite il file TOOLS.INI, reperibile nella stessa cartella in cui è installato zipgenius.exe. Nel file "tools.ini" lo strumento deve creare una sezione come indicato nell'esempio seguente:

[Collector]
cmd=C:\COLLECTOR\COLLECTOR.EXE
caption=Colleziona archivi
params=-zg
results=c:\windows\deskop\result.txt
fileopen=0
senadarcname=0
sendselected=0
sendall=0

In questo esempio sono elencati tutti i parametri OBBLIGATORI da utilizzare nella sezione.

CMD
In questo parametro lo ZGTool deve indicare il proprio percorso, altrimenti ZipGenius non potrà usarlo.

CAPTION
Qui bisogna inserire la voce del menù che apparirà in fondo al menù "STRUMENTI " di ZipGenius, dal quale potrà essere avviato lo ZGTool.

PARAMS
Qui bisogna indicare gli eventuali parametri da aggiungere alla linea di comando dello strumento: vedere anche SendArcName, SendSelected e SendAll .

RESULTS
Se lo strumento che si è creato scrive un file con i risultati dell'operazione eseguita, ZipGenius lo potrà leggere tramite il percorso indicato in questo parametro.

FILEOPEN
Qui puoi indicare se lo ZGTool deve essere usato solo se è un archivio è aperto in ZipGenius: "1" significa "vero", "0" significa "falso" (lo ZGTool può funzionare sempre).

SENDARCNAME
Se questo valore è uguale a "1", alla lista dei parametri inserita in Params, sarò aggiunto il percorso e il nome del file-archivio attualmente aperto.

SENDSELECTED
Se questo valore è uguale a "1", alla lista dei parametri inserita in Params saranno aggiunti i nomi dei files selezionati nella finestra di ZipGenius.

SENDALL
Se questo valore è uguale a "1", alla lista dei parametri inserita in Params saranno aggiunti i nomi di tutti i files elencati nella finestra di ZipGenius.

Suggerimenti per lo sviluppatore:

  1. Per sapere in quale cartella si trovano i files zipgenius.exe e tools.ini, basta leggere il valore AppPath nella sezione [DLL] del file zipgenius.ini, posto nella cartella di Windows (es.: c:\windows\zipgenius.ini). Lo ZGTool deve provvedere a questa operazione, quindi dovrà rilevare la propria posizione e riportarla nel valore CMD della sua sezione.
  2. Puoi creare anche più di una sezione in tools.ini se il tuo strumento compie più di una azione: l'importante è che lo ZGTool provveda a creare due sezioni distinte. Esempio:

    [Collector_1]
    cmd=C:\COLLECTOR\COLLECTOR.EXE
    caption=Colleziona archivi
    params=-zg
    results=c:\windows\deskop\result.txt
    fileopen=0

    [Collector_2]
    cmd=C:\COLLECTOR\COLLECTOR.EXE
    caption=Collezionaarchivi ZIP e CAB
    params=-zg-zip -cab
    results=c:\windows\deskop\result.txt
    fileopen=0
  3. Quando crei il setup dello ZGTool e la relativa procedura di disinstallazione, assicurati che le sezioni create dal tuo strumento siano rimosse dal file tools.ini, e che lo stesso file non sia rimosso accidentalmente.
  4. Lo ZGTool non deve necessariamente essere un file eseguibile: con il metodo usato in ZipGenius puoi usare anche script in VBScript, JavaScript e files .BAT e .COM.
  5. Se il tuo ZGTool crea un file di risultati, fa sì che il file stesso inizi con il nome dello ZGTool, il tuo nome e persino con il tuo indirizzo e-mail o l'indirizzo della tua homepage: ZipGenius mostrerà il file nel visualizzatore interno, che è in grado di leggere i collegamenti Internet (hyperlinks).
  6. Entro breve termine verrà rilasciato una utility per la creazione della procedura di iscrizione degli ZGTools, quindi consulta periodicamente il sito M.Dev Software.
  7. Puoi personalizzare il Setup del tuo ZGTool con il logo [image] che puoi scaricare da qui.
  8. Fa' in modo che l'installazione dello ZGTool rilevi la lingua in uso con ZipGenius, così da poter inserire il titolo della voce del menù nella lingua corrispondente

Per ottenere maggiore aiuto o altri suggerimenti è possibile contattare M.Dev Software.


Spedire o pubblicare un archivio o un file estratto da un archivio.

Internet: spedire un archivio o un file da un archivio

Questa versione di ZipGenius è stata progettata con una maggiore integrazione delle funzioni per Internet. Tutte queste sono accessibili tramite il tasto .

Premendo questo tasto apparirà un menù con le funzioni Internet disponibili secondo la configurazione prescelta:

Conf. normale

Conf. per esperti

Scarica archivio.
Selezionando questa voce del menù apparirà una finestra in cui potrai scrivere l'indirizzo Internet del file che vuoi scaricare. E' possibile scaricare solo files corrispondenti ai formati di archivio supportati da ZipGenius e l'indirizzo deve NECESSARIAMENTE iniziare con "http://" o "ftp://".

Invia in allegato.
Nella configurazione normale è possibile solo inviare un intero archivio come allegato. Si aprirà un sottomoneù con una sola voce, cliccando sulla quale sarà avviato il programma e-mail predefinito, già pronto per la creazione di un nuovo messaggio e con l'archivio già allegato.

Nella configurazione per esperti, invece, il sottomenù presenta anche la voce File, la quale è disponibile solo se si seleziona un file contenuto nell'archivio correntemente aperto. Tramite questa funzione, è possibile estrarre uno o più files da un archivio e invirali come allegati ad un messaggio e-mail.

Pubblica su Internet .
Anche a questa funzione è collegato un sottomenù che si comporta identicamente a quello relativo all'invio in allegato, così se è impostata la configurazione per esperti, potrai anche pubblicare uno o più files estratti dall'archivio attualmente aperto in ZipGenius.

Per pubblicazione su Internet si intende il trasferimento di un file su un sito Web, quindi se disponi di un tuo spazio su Web puoi trasferire i tuoi archivi nello stesso spazio in cui sono ospitate le pagine del tuo sito. ZipGenius esegue ciò tramite FTPGenius, il client FTP incorporato, il quale provvederà ad avviarsi, connettersi ad un sito FTP a scelta dell'utente e a trasferire i files selezionati o l'archivio correntemente aperto.

Esporta lista dei files e...
Queste due funzioni sono disponibili solo dopo aver attivato la configurazione per esperti e consente di allegare la lista dei files ad un messaggio e-mail oppure di pubblicarla su un sito Web; nel primo caso la lista dei files costituirà il testo del messaggio e-mail, mentre nel secondo la lista sarà esportata in formato HTML e pubblicata secondo la modalità sopra descritta.


ZipGenius Mail

ZipGenius dispone di un programma e-mail incorporato le cui funzioni sono limitate al solo invio di messaggi con files allegati. Questo componente di ZipGenius può risultare utilissimo nei casi in cui il programma e-mail predefinito nel sistema non sia MAPI-compatibile, quindi non in grado di ricevere istruzioni da ZipGenius per l'invio di posta elettronica.

L'impostazione predefinita di ZipGenius lascia che sia il programma e-mail predefinito ad occuparsi dell'invio di messaggi e-mail, perciò per attivare ZipGenius Mail occorre aprire il pannello delle Opzioni e selezionare la casella " Invia e-mail usando ZipGenius Mail"; dopo aver premuto "OK", ZipGenius ignorerà qualsiasi altro programma e-mail e userà semplicemente ZipGenius Mail.

Istruzioni per ZipGenius Mail.
Come accennato, ZipGenius Mail è un client e-mail limitato nelle funzioni. In particolare non è possibile:

  • ricevere posta elettronica;
  • inviare messaggi a più destinatari in copia carbone nascosta (Ccn).

Per inserire l'indirizzo di un destinatario si può digitarlo nell'apposita casella accanto al tasto"A:" e premere il tasto "6" per aggiungerlo alla lista, oppure si può premere il citato tasto "A:" per aprire la Rubrica di Windows; usando quest'ultimo sistema, gli indirizzi immessi nelle liste "CC:" o "CCn:" saranno ignorati.

Per aggiungere allegati premere "Allega file ": i files selezionati saranno aggiunti alla relativa lista, da cui è possibile rimuoverli selezionandone il nome e premendo "Canc " (o "Del") sulla tastiera.

Nella casella " SMTP" bisogna indicare l'indirizzo del server SMTP (posta in uscita) che si usa normalmente, mentre nella casella " Porta" occorre indicare la porta usata dal suddetto server (normalmente è sufficiente lasciare il valore " 25"); se non conosci questi dati:

  • puoi rivolgerti al tuo Internet Provider;
  • puoi leggerli sul sito Web del Provider, nella pagina dell'assistenza clienti;
  • puoi ricavarli dalle istruzioni che il tuo Provider ti ha fornito quando ti sei abbonato;
  • puoi ricavarli dalle opzioni del programma di posta elettronica .

Questi dati saranno memorizzati da ZipGenius in modo da non doverli inserire nuovamente al successivo invio di posta elettronica.

Nella casella " Oggetto" puoi indicare l'oggetto del messaggio.

Nella casella " Indirizzo e-mail del mittente" devi scrivere il tuo indirizzo e-mail (per ricevere l'eventuale risposta), mentre nella casella " Nome utente" devi indicare il tuo nome (altrimenti la connessione al server della posta fallirà).

Infine puoi scrivere un messaggio.

Per inviare il messaggio premi "Invia".

La finestra "Stato" mostrerà solo l'andamento della connessione e il susseguente invio del messaggio; se il messaggio sarà stato inviato con successo, la finestra si chiuderà automaticamente.


FTPGenius

FTPGenius è il client FTP incorporato in ZipGenius tramite cui fino ad oggi era possibile scaricare automaticamente gli archivi zip dai vari siti e aprirli subito dopo con ZipGenius; da adesso, però, FTPGenius si è evoluto e si comporta come un vero e proprio client FTP, dando perciò la sensazione di avere due programmi in uno (e per giunta gratuiti).

Novità
FTPGenius non è più limitato al solo download degli archivi zip ed exe dai siti FTP: oggi è possibile scaricare qualsiasi tipo di file e persino è possibile eseguire il cosidetto "upload" su un server FTP, come ad esempio accade ogni volta che si vuole costruire un sito Web.
Inoltre, grazie alla tecnica DualApp™ , FTPGenius può essere avviato dal menù Start come se fosse un'applicazione indipendente (invece è perfettamente incorporata in ZipGenius).

Avvio di FTPGenius
Usare FTPGenius è molto semplice. Per avviarlo occorre avere ZipGenius aperto, oppure si può usare subito FTPGenius cliccando sulla relaitva icona nel menù Avvio; dalla riga di comando, invece, può essere avviato con il parametro "-ftpg": ZipGenius si avvierà e passerà subito a FTPGenius.

Uso
Per iniziare una connessione occorre premere il tasto "Connetti". Apparirà la seguente finestra:

Creare una nuova connessione
Nella casella "Descrizione" puoi immettere una descrizione del sito FTP cui ti stai per connettere (es.: "Microsoft"); successivamente in "Indirizzo" scrivi l'indirizzo del sito FTP (es.: "ftp.microsoft.com"), il tuo nome utente ("Username") e la tua password.
Se il sito lo consente puoi anche accedere anonimamente, cioé senza immettere username e password: per far ciò seleziona la casella "Accesso anonimo", con la quale il programma inserirà uno username e una password fittizi.
Se desideri che questa conessione sia inserita nella lista delle connessioni preferite, clicca sul pulsante "Salva", quindi premi "OK" per iniziare la connessione.

Usare una connessione creata in precedenza
Puoi iniziare a digitare il nome della connessione nella casella descrizione: FTPGenius proverà ad individuare automaticamente le impostazioni per la connessione richiesta; se vuoi puoi anche vedere la lista delle connessioni e selezionarne una: premi il tasto con la freccia nera.
Fatto ciò, premi "OK" per iniziare la connessione.

Per cancellare una connessione, selezionala dalla lista e premi "Cancella".

A connessione eseguita vedrai apparire il contenuto della cartella principale del server FTP nella finestra inferiore di FTPGenius: troverai files e/o cartelle. Per cambiare cartella clicca due volte sulla sua icona e attendi che si aggiorni la finestra.
Nella finestra superiore, invece, vedrai il contenuto del tuo Desktop e anche qui potrai cambiare cartella in due modi:

  1. cliccando due volte sulla cartella in cui desideri spostarti
  2. digitando il percorso della cartella da raggiungere e premendo il tasto "Vai"

Con una connessione FTP attiva potrai prelevare files dal server FTP e scaricarli nella cartella che appare nella finestra superiore, oppure potrai inviare files dalla cartella selezionata sul tuo PC alla cartella selezionata sul server FTP.

Download: prelevare files dal server FTP
 Seleziona uno o più files nella finestra inferiore di FTPGenius, quindi premi il tasto [image] per iniziare il download; nella barra di stato vedrai un indicatore che ti aiuterà a capire l'avanzamento dell'operazione. Terminato il download, la finestra superiore si aggiornerà automaticamente per mostrare anche il file scaricato nella cartella prescelta e ZipGenius controllerà se quel file appartiene ad uno dei tipi di archivio supportati dal programma; se hai scaricato un solo file e questo è uno degli archivi supportati, ZipGenius chiederà se vuoi aprirlo immediatamente. In caso di risposta affermativa, FTPGenius chiuderà l'eventuale connessione ancora aperta e scomparirà per fare apparire la finestra di ZipGenius con il contenuto dell'archivio appena scaricato.

Upload: inviare files ad un server FTP
Seleziona uno o più files da inviare nella finestra superiore di FTPGenius, quindi premi il tasto [image] per iniziare l'invio. Nella barra di stato vedrai un indicatore che ti aiuterà a capire l'avanzamento dell'operazione. Finito l'invio, la finestra inferiore si aggiornerà e mostrerà il contenuto della cartella del server FTP con i nuovi files.

Creare, rinominare e cancellare cartelle dal server FTP
Queste operazioni non sono sempre consentite dai servers FTP, ma sono generalmente utilizzabili se ci si connette al server FTP che ospita il proprio sito Web.

Per creare una nuova cartella premi il tasto [image]. FTPGenius ti chiederà il nome da assegnare alla nuova cartella. Dopo aver confermato l'operazione vedrai aggiornarsi la finestra inferiore del programma, così da poter mostrare anche la cartella appena creata.

Per rinominare una cartella, selezionane una nella finestra inferiore di FTPGenius e premi il tasto [image] e digita il nuovo nome per la cartella.

Per cancellare un file (o una cartella), selezionalo e premi il tasto [image] .

Altre funzioni

"Trasferimento files" permette di impostare il tipo di trasferimento da attivare durante il download o l'upload di files; i files di testo devono essere trasferiti con l'opzione ASCII, mentre per tutti gli altri files deve essere usata l'opzione Binario. Tuttavia è possibile far scegliere al programma il trasferimento adeguato: basta selezionare l'opzione Automatico .


UUencode, XXencode, MIME Base 64

I files sono generalmente distinti in due famiglie: files "BINARI" e files "ASCII", dove questi utlimi altro non sono che files contenenti del testo; per fare un esempio, un file .zip o un file .gif sono files binari, poiché non contengono del testo ma il loro contenuto è codificato in forma "binaria" (tanti "0" e "1" in successione), mentre un file .txt è un file ASCII, giacché il contenuto è esclusivamente del testo.

In determinate occasioni su Internet non è possibile inviare files nella loro naturale forma binaria, cosicché diverrebbe impossibile il trasferimento di quei files: basti pensare ad alcuni newsgroups che accettano messaggi senza files binari allegati; in queste situazioni ZipGenius può intervenire trasformando qualsiasi tipo di file (e non solo gli archivi nei formati supportati) in files testuali che possono aggirare la suddetta limitazione; sarà poi il destinatario del file a dover decodificare quei files utilizzando il metodo inverso a quello usato per la codifica.

ZipGenius supporta tre metodi di codifica largamente diffusi.

UUencode: è il più antico fra i tre ed era originariamente progettato per i sistemi operativi UNIX. I files codificati con questo metodo sono riconoscibili per le estensioni .uu e .uue, mentre ZipGenius produce files con la sola estensione .uue.

XXencode: è un metodo simile a UUencode, ma del quale è considerato come una evoluzione volta a risolvere alcuni problemi di quello, come - per esempio - la non perfetta conversione secondo la tavola dei caratteri ASCII. I files codificati con questo sistema hanno l'estension .xxe.

MIME Base 64: questo è il metodo attualmente più diffuso poiché è nato contemporaneamente alla diffusione dei sistemi di posta elettrnoica via Internet. Tutti i programmi e-mail oggi codificano i messaggi nel formato MIME e i files codificati con questo metodo sono riconoscibili per l'estensione .mim e .b64.

Per codficare un file qualsiasi o l'archivio correntemente aperto basta aprire il menù "Azioni" e selezionare il metodo di codifica (o di decodifica) che si desidera usare: se nessun archivio è aperto in ZipGenius, il programma farà apparire un dialogo da cui potrai scegliere qualsiasi file da codificare (o decodificare). Al termine dell'operazione il programma darà conferma della riuscita e mostrerà il nome del file generato dalla codifica.


Problemi e soluzioni

D: ZipGenius si è bloccato oppure ha bloccato il sistema dopo una data azione: cosa devo fare?

R: Riavvia il sistema e invia un messagggio e-mail a mdevsoftware@hotmail.com. Ricordati di inserire una descrizione dettagliata del tuo PC e delle circostanze in cui si è verificato il problema.

D: Uso Outlook 2000. Quando provo ad inviare un archivio (oppure uno o più files estratti) via e-mail, a volte ricevo il messaggio "Failed connection to e-mail program", quindi "Archivio spedito".

R: Non importa: Outlook 2000 spedirà comunque l'allegato.

D: Non riesco a creare archivi autoestraenti (SFX).

R: Verifica che nella cartella di ZipGenius vi siano i files sfx_it.bin, sfx_en.bin, autosfx_it.bin, autosfx_en.bin. Se non sono presenti occorre reinstallare il programma, ma se sono presenti puoi inviare un messaggio a M.Dev Software riportante la configurazione dettagliata del tuo sistema e gli altri programmi in esecuzione quando il problema si è verificato.

D: ZipGenius mostra errori relativi ai files "UnzDLL.dll" e "ZipDLL.dll".

R: Le cause possibili sono le seguenti:

  • I suddetti files sono danneggiati
  • I suddetti files sono mancanti
  • I suddetti files sono presenti ma il loro numero di versione è inferiore a 1.6

Nei primi due casi occorre reinstallare ZipGenius, mentre per controllare il numero di versione dei files citati basta seguire la procedura riportata sotto:

  • Clicca sul tasto Start e attendi la comparsa del menù relativo.
  • Clicca su "Esegui..." e digita il percorso completo del file zipgenius.exe, seguito dall'opzione "-test" (senza le virgolette).
    ESEMPIO: c:\programmi\zipgenius\zipgenius.exe -test
  • ZipGenius avvierà la procedura di autodiagnosi e scriverà sul desktop il file zg14diag.txt, nel quale riporterà tutti gli inconvenienti rilevati per quel che riguarda l'installazione di ZipGenius (e non anche per le impostazioni effettuate).

D: ZipGenius legge il contenuto di archivi in formato diverso dallo ".zip" ma non può modificarne il contenuto (estrarre, aggiungere o cancellare files), nè può installare i programmi in essi contenuti.

R: ZipGenius è stato originariamente progettato per i soli archivi zip e solo di recente è stato riprogrammato in modo tale da poter leggere il contenuto di archivi in formato diverso; tuttavia per poter gestire tali archivi quasi come fossero files zip è necessario usare programmi esterni che ZipGenius può controllare. (Vedi: Formati diversi)

D: Ho aperto un file del tipo ".ZOO" ma ottengo una lista dei files ridotta rispetto a quanto ottengo con altri programmi.

R: ZipGenius usa un algoritmo per la lettura dei files ".ZOO" compatibile con file prodotti da zoo.exe fino alla versione 2.0. I files prodotti da versioni successive potrebbero essere letti male e - comunque - archivi compressi e files eseguibili inseriti in un archivio ".zoo" creano problemi con la lettura del file stesso.

D: Su Windows 2000 il menù contestuale associato ai files zip non funziona, quindi non riesco a spedire archivi via e-mail senza aprire il programma principale, nè a creare archivi auto-estraenti.

R: Questo è un problema rilevato già durante il beta testing del programma. Per maggior sicurezza di risposta sono stati installati altri programmi concorrenti e anche in essi è stato rilevato il problema, che - a questo punto - dovrebbe essere attribuito a Windows 2000 stesso. Questo sistema operativo, infatti, presenta una diversa gestione delle interfacce COM (COM+) creando così delle incompatibilità con alcuni software sviluppati principalmente per Windows 95/98. E' consigliabile visitare regolarmente il sito M.Dev Software per sapere se è stato possibile o meno risolvere il problema (dipende tutto da Windows 2000).

D: ZipGenius è molto lento.

R: ZipGenius 1.4 è stato completamente riscritto e non soffre più di alcune limitazioni tecniche del suo predecessore ZipGenius Evoluzione. Quest'ultima versione è stata sviluppata su un PC dotato di CPU Intel® Celeron® 433 MHz ed è stato testato su diversi sistemi con diverse configurazioni, fornendo - ovviamente - prestazioni diverse. Molto probabilmente la lentezza di ZipGenius sul tuo sistema è causato da una configurazione hardware non conforme ai requisiti minimi richiesti , oppure da una configurazione errata del software di sistema.


Aggiungere cartelle

E' possibile aggiungere il contenuto di una intera cartella. La procedura per far ciò è diversa secondo la configurazione scelta: in modalità "NORMALE" basterà selezionare l'opzione aggiungi cartella nell'Assitente di ZipGenius, mentre se hai scelto la configurazione "ESPERTO" senza Assistente dovrai premere il tasto con la freccia nera accanto ad "Aggiungi". Comparirà un menù in cui dovrai selezionare "Aggiungi cartella", quindi dovrai selezionare la cartlla da aggiungere all'archivio.

Le opzioni sono le stesse disponibili per l'inserimento dei files .


DeCryptoZip

DeCryptoZip (di serie nell'edizione SUITE)

Questo è l'unico ZGTool che non troverete installato nel menù Strumenti di ZipGenius, in quanto non è destinato agli utenti di ZipGenius 1.4, bensì a quelli delle versioni precedenti, le quali non erano in grado di gestire il formato .CZIP (archivi zip criptati).

Quando dovrai inviare un archivio czip ad un utente di una versione "vecchia" di ZipGenius (o ad un utente di altri programmi concorrenti), gli potrai anche inviare questo ZGTool, che provvede alla decriptazione degli archivi czip.

Il suo uso è molto semplice: basta scegliere un file czip premendo il tasto "Open...", quindi inserire la stessa tripla chiave numerica usata per la criptazione dell'archivio; infine, basta premere "Decrypt" e l'archivio sarà convertito in un file zip tradizionale.

ATTENZIONE! Usare una chiave errata comporterà l'errata decodifica dell'archivio.


Disk Span

L'operazione definita Disk Spanning sta ad indicare la possibilità di ripartire un grosso archivio zip su un set di due o più floppy disks.

Per poter usare questa funzione è necessario innanzi tutto aprire un file zip, quindi premere il tasto [image] Disk Span ; successivamente basterà seguire le istruzioni date da ZipGenius passo dopo passo.

L'operazione inversa si definisce Unspanning e diventa accessibile, dopo aver aperto un file zip da un floppy, solo se ZipGenius lo identifica come un archivio distribuito su floppy. Con questa operazione il file che si trova diviso su più floppy verrà ricostruito in una qualsiasi cartella del sistema scelta dell'utente. Per attivarla occorre premere il tasto [image] Unspan.


Domande frequenti (FAQ)

D: Perché ZipGenius è freeware?

R: Per le versioni precedenti ero solito sostenere (dal 1998) che un programma di compressione dovrebbe essere di serie in un sistema operativo come Windows; oggi Windows Millennium Edition sembra avere recepito questa teoria e offre la possibilità di comprimere le cartelle del sistema. Oggi sostengo che ZipGenius continua ad essere freeware per due motivi:

  1. lo zip incorporato in Windows ME sembra gratuito: in realtà lo pagate nel momento in cui acquistate una copia di Windows, che freeware non è di certo;
  2. perché il livello di qualità raggiunto dalla versione 1.4 di ZipGenius è tanto alto da far impallidire lo zip di serie di Windows ME.

D: Perché ZipGenius ha 5 motori zip?

R: Per rendere più flessibile e veloce l'impiego delle varie sezioni del programma. Un esempio un po' tecnico: il menù contestuale associato ai files zip è contenuto in una libreria DLL, la quale può contenere di tutto, persino un piccolo motore zip. Che bisogno c'era di far partire il programma principale solo per avere disponibili i motori zip di questo, quando la stessa libreria poteva contenerne uno? Così è stato: il menù contestuale comanda il proprio motore zip, senza "richiamare" il programma principale (come invece fanno programmi zip ben più famosi ;-) ); il risparmio di tempo è davvero sensibile, perciò questo metodo è stato applicato ovunque servisse l'esecuzione immediata di un'operazione da parte di un motore zip. Il risultato più evidente è una maggior armonia di esecuzione da parte di tutto il programma.

D: Esisteranno altre versioni localizzate dal punto di vista del linguaggio?

R: Per il momento non sono previste.

D: Su quali sistemi operativi è utilizzabile ZipGenius?

R: ZipGenius 1.4 è nato su Windows 98 e su Windows 2000, perciò alcune caratteristiche dei dialoghi di apertura sono tipiche di questi sistemi operativi; queste peculiarità, però, non sono disponibili se si installa ZipGenius su Windows 95 o su Windows NT4, nei quli i dialoghi di apertura dei files erano inestensibili e non dimensionabili. Per evitare errori e problemi vari, ZipGenius esamina il sistema operativo che lo ospita e determina se è possibile usare i dialoghi di apertura avanzati .
In definitiva, ZipGenius è installabile sui seguenti sistemi:

    • Windows 95 (è necessario avere Internet Explorer 4.0 installato)
    • Windows 98 / Windows 98 SE /Windows ME
    • Windows NT (è necessario avere Internet Explorer 4.0 installato)
    • Windows 2000

D: Perché ZipGenius ha pochi menù disponibili?

R: A dire la verità, quelli già presenti per me sono troppi. Ho sempre pensato che i menù non siano la cosa migliore per un programma dotato di numerose funzioni come ZipGenius 1.4, poiché essi tendono a nasconderle e a confondere le idde agli utenti meno avvezzi all'uso del PC. Ho preferito, invece, raccogliere tutte le funzioni nell'assistente "Primo passo", in cui basta scorrere l'elenco elle azioni disponibili e sceglierne una. Il disegno originale del programma prevedeva addirittura la totale assenza dei menù (escluso quello rapido).

D: Qual è l'elemento caratterizzante di ZipGenius?

R: ZG 1.4 è stato progettato soprattuto per fornire la massima semplicità d'uso e le maggior versatilità. Per ZipGenius la velocità è solo un dettaglio utile per eseguire dei paragoni con i concorrenti.

D: Vorrei spedire un file zip criptato ad un mio amico che ha solo ZipGenius Evoluzione: come potrà fare per leggerne il contenuto?

R: E' semplice ti basta inviargli anche DeCryptoZip, lo ZGTool creato esclusivamente per garantire la retrocompatibilità con le vecchie edizioni di ZipGenius, oppure puoi consigliarglidi scaricare ZipGenius 1.4. Ricorda anche che dovai inviargli la combinazione numerica che hai usato per criptare l'archivio.


Estrarre files

La funzione di estrazione dei files è unica per entrambe le configurazioni del programma, anche se le opzioni cambiano da un formato di archivio all'altro.

Per iniziare l'estrazione bisogna premere il tasto [image] Estrai. Apparirà la seguente finestra:

Se nessun file nella finestra di ZipGenius è stato selezionato, l'opzione "Tutti i files" sarà attivata automaticamente; se invece uno o più files sono stati selezionati, sarà attivata l'opzione "Solo files selezionati". In alternativa è possibile scegliere l'opzione "Solo files del tipo" con cui possono essere estratti i files con la stessa estensione (che dovrà peraltro essere indicata nell'elenco a scomparsa laterale).
L'opzione "Cartella",invece. è utile quando l'archivio contiene diverse cartelle e sottocartelle: ne potrai estrarre anche una sola, selezionandola nell'apposito elenco. ZipGenius automaticamente si disporrà in modo tale da estrarre anche le sottocartelle contenute in quella selezionata. Se, invece, l'archivio non contiene cartelle, questa opzione non sarà disponibile.

Usa percorsi salvati
Con questa opzione saranno ricostruiti i percorsi originali dei files archiviati, se questi erano stati compressi con le informazioni sul loro percorso (praticamente: se la colonna "Percorso" nella finestra principale non è vuota).

Apri cartella di destinazione
Al termine dell'estrazione sarà aperta la cartella di destinazione dei files da estrarre.

Al termine dell'estrazione avvia l'installazione
Questa opzione è disponibile soltanto se nell'archivio è contenuto un programma di installazione "Setup.exe" e permette di avviare l'installazione del programma zippato dopo aver estratto tutti i files ad esso collegati. E' consigliabile verificare se i files siano stati compressi on le informazioni sui percorsi originali: se così non fosse è opportuno attivare anche l'opzione "Usa percorsi salvati", altrimenti l'installazione del programma potrebbe fallire. Se non sai cosa fare premi il tasto "Primo passo" e scegli la voce "Installare un programma".

Al termine dell'estrazione chiudi ZipGenius
Ad estrazione terminata il programma si chiuderà da sè.

E' necessario scegliere il tipo di estrazione da effettuare fra quattro disponibili:

  1. Non sovrascrivere - se un file con lo stesso nome di quello da estrarre è già esistente, ZipGenius non lo estrae.
  2. Sovrascrivi sempre i files esistenti - Se identici ai files da estrarre, ZipGenius sostituisce tutti i files esistenti nella cartella di destinazione.
  3. Estrai e aggiorna i files esistenti - se i files omonimi esistenti sono più vecchi di quelli da estrarre, saranno sostituiti da queli più recenti.

Destinazione
Scrivi il percorso della cartella in cui desideri estrarre i files zippati oppure premi il tasto "Sfoglia". Ogni percorso inserito sarà memorizzato, così se dovrai usarlo ancora potrai selezionarlo nell'elenco a scomparsa.
Selezionando l'opzione "Crea cartella con il nome dell'archivio" potrai fare in modo che ZipGenius crei nel percorso indicato come destinazione una cartella con lo stesso nome dell'archivio. Es.: dall'archivio "prova.zip", potrai estrarre i files in "[destinazione]\prova ".


Il menù rapido

ZipGenius 1.4 è stato progettato - come i suoi predecessori - per consentire il miglior uso del tasto destro del mouse. Cliccando all'interno della finestra del programma apparirà il menù mostrato nella figura in alto, nel quale le funzioni saranno più o meno disponibili secondo il tipo di archivio correntemente aperto. Da qui è possibile quindi attivare tutte le funzioni principali del programma, nonché quelle legate a Internet.


Rinominare un archivio


Statistiche

Questa funzione permette di ottenere maggiori dettagli sul file Zip attualmente aperto. In particolare permette di leggere la percentuale corrispondente al rapporto di compressione medio per l'intero archivio, qual è il file più compresso e quale è quello meno compresso.
Inoltre si può consultare il "Rapporto cartelle", tramite cui si potrà sapere la dimensione originale e compressa, e il rapporto di compressione di ogni cartella inserita nell'archivio.

Rapporto compressione

Rapporto cartelle


Time To Get!

Time To Get! (di serie nell'edizione SUITE)

Questo ZGTool è l'evoluzione di quella utility già conosciuta con il nome di ETD Calculator.

La sua funzione è quella di calcolare il tempo (stimato) richiesto per scaricare un file a diverse velocità di connessione.

Usarlo da ZipGenius (come ZGTool) è molto semplice: basta aprire un archivio e selezionare il comando "Time To Get!" nel menù Strumenti; il risultato apparirà nella finestra del visualizzatore interno, oppure, selezionando il comando "Time To Get! - HTML", ti sarà chiesto in quale cartella salvare il file HTML che lo ZGTool creerà.

Se usato come applicazione indipendente, invece, bisognerà:

  1. selezionare un file cliccando sul tasto "Browse";
  2. cliccare su "Calculate" per sapere i diversi tempi stimati;
  3. opzionalmente potrai cliccare su "Export to HTML" per esportare i risultati in un file HTML.